Art Studio:绘图工具和画布控件
绘图功能可用于绘制像素、创建可编辑文本、制作逐帧动画,以及准备纹理或九宫格面板。你可以在同一个 Art Studio 项目中组合使用这些工具,之后也能返回项目继续编辑。
熟悉工作区
- **顶部工具栏:**关闭、撤销/重做、File 菜单,以及工作区操作和模式菜单。使用 File 保存可编辑项目,或导出游戏素材。
- **工具栏:**选择绘图或选区工具。画布上方的选项会随所选工具而变化。
- **画布:**棋盘格表示透明区域。这只是显示辅助,不会包含在导出的图像中。
- **缩放控件:**显示当前缩放百分比,并提供缩放和适应画布的控件。只有放大到足以清晰显示时,像素网格才会出现;切换网格不会改变缩放比例。
- **检查器:**Preview、Layers 和 Palette 是常用标签页。选择 Transform、Text 或调整等工具时,会显示相应的面板。
- **时间轴:**启用 Modes → Keyframe Animation 后显示。请参阅逐帧动画。
在较窄的窗口中,控件可能会显示为图标或移入菜单,检查器则会位于画布下方。滚动控件行或检查器即可访问其余选项。使用鼠标悬停在图标上可查看其提示。
移动画布而不进行绘制
在 iPad 上,用两指平移并捏合缩放。使用触控板时,用两指滚动来平移;滚动时按住 Command 可缩放。使用鼠标滚轮可围绕指针位置缩放。触控板捏合也可缩放。按 0 可使画布适应窗口,按 ⌘1 可缩放至 100%。
单指、Apple Pencil 或主键拖动会使用当前选定的绘图工具。双击并不是缩放画布的快捷方式:在可编辑文本上使用 Transform 工具时,双击可开始编辑文本。
选择工具
当画布处于键盘焦点时,可使用以下单字母快捷键。这些快捷键不会替换你正在字段中输入的文本。
| 工具 | 按键 | 用途 |
|---|---|---|
| Pen | P | 根据所选笔刷预设绘制自由像素或笔刷笔画。 |
| Mirror Pen | V | 沿垂直、水平或两条镜像轴对称绘图。 |
| Fill | B | 填充相连像素;使用 Global 模式时,可填充目标范围内所有匹配的像素。容差用于控制颜色需要匹配到什么程度。 |
| Replace Color | A | 根据所选编辑范围替换取样颜色。 |
| Eraser | E | 擦除像素,显露透明区域或下方图层。 |
| Smudge / Blend | N | 拖动已有颜色,使其与附近像素混合。可调整强度和笔刷大小。 |
| Line | L | 在两点之间绘制直线。 |
| Rectangle | R | 使用 Outline 或 Fill 绘制矩形。 |
| Ellipse | C | 使用 Outline 或 Fill 绘制圆形或椭圆。 |
| Linear Gradient | G | 沿拖动的直线混合颜色。 |
| Radial Gradient | K | 从起点向外混合颜色。 |
| Text | T | 创建或编辑文本图层。 |
| Transform | M | 移动、缩放、旋转或以其他方式变换选区或图层。 |
| Magic Select | Z | 选中颜色匹配的相连像素区域。 |
| Rectangle Select | S | 拖动创建矩形选区。 |
| Lasso | H | 绘制自由选区边界。 |
| Lighten | U | 反复涂抹像素,逐渐形成较亮的色调。 |
| Darken | J | 反复涂抹像素,逐渐形成较暗的色调。 |
| Dither | Q | 应用图案混色效果,适用于像素着色。 |
| Eyedropper | O | 从图稿中取样颜色。 |
使用形状和渐变工具时,拖动以预览,然后使用显示的 Apply 控件或按 Return 确认。按 Cancel 或 Escape 可关闭预览。预览期间,你可以在确认形状前更改其选项。
像素艺术与绘画
选择 Pixel Art 笔刷,可获得精确的方形笔尖和整数像素定位。若要进行柔和绘画,请选择绘画笔刷并打开 Brush Settings(⌘B)。大小、硬度、不透明度、流量、间距、压力、倾斜和纹理等选项可用于塑造笔画。Pixel Art 会保持精确的栅格行为;压力和柔化不会改变其像素。
几何工具有独立的 Pixel/Smooth 选项。选择像素渲染可获得清晰的精灵边缘;平滑渲染则会添加抗锯齿。运行时纹理过滤是另一项输出设置:更改绘图工具不会自动改变游戏中素材的采样方式。
使用 [ 和 ] 更改笔刷大小。使用 Lighten 或 Darken 时,适度的强度更便于控制;无需抬起笔刷,也可以重复涂抹同一区域来逐步增强效果。
颜色与调色板
使用主色和辅色样本块打开对应的拾色器。按 X 可交换两种颜色;按 D 可将其重置。在 Palette 标签页中选择调色板,或整理其中的色样。数字键 1–9 可选择调色板中的前九种颜色。拾色器支持精确输入颜色,便于在多个素材中重复使用相同颜色。
使用图层
打开 Layers,选择 New Layer,然后选择 Pixel Layer 或 Text Layer。绘图前先选中要编辑的行。图层缩略图显示该图层的图稿,画布则显示所有可见图层合成后的效果。
使用眼睛按钮隐藏图层,使用不透明度控件调整其透明程度。隐藏图层不会将其删除。长按图层或单击辅助键可打开图层的上下文菜单,执行重命名、复制、向下合并、蒙版和调整等操作。对于预计要单独重新着色或制作动画的部分,请将它们保存在不同图层中。
| 图层功能 | 作用 |
|---|---|
| Blend mode | 更改图层与其下方图层的合成方式:Normal、Multiply、Screen、Add 或 Erase。 |
| Alpha Lock | 重新着色图层时保留现有透明度。 |
| Clipping Mask | 将图层限制在下方图稿的范围内。 |
| Layer Mask | 隐藏或显示图层的部分内容,而不擦除其源像素。可创建全显示蒙版,或根据选区创建蒙版。选择 Artwork 或 Mask 作为编辑目标。 |
| Groups | 整理相关图层;组可见性可让你同时隐藏一组图层。 |
| Merge Down | 将所选图层与下方图层合并。如果想保留这些独立部分,请先保存项目副本。 |
常用图层快捷键:⇧⌘N 新建像素图层,⌘J 复制图层,⌘E 向下合并,⌘[ / ⌘] 将图层向后/向前移动,⇧⌘L 打开 Layers。
选择、变换和裁剪
- 选择 Rectangle Select、Lasso 或 Magic Select。
- 创建选区。使用矩形或套索工具时,请拖动而不要只单击一下。
- 选择 New、Add、Subtract 或 Intersect,以控制下一个选区与现有选区的组合方式。羽化可柔化选区边缘;若要获得清晰的像素边缘,请将其设为零。
- 在选区内绘图、复制、删除或变换内容,也可以裁剪到选区边界。
在 New 选区模式下,单击现有矩形/套索选区以外的位置会清除该选区;单击选区内部则会保留它。按 ⌘D、Escape 或选择 Clear Selection 可明确取消选区。按 ⌘A 可全选,按 ⇧⌘I 可反转选区。Selection 菜单还提供 Select Opaque Pixels 和向外扩展/向内收缩一个像素的操作。
选择 Transform(M 或 ⌘T)可处理所选像素或图层。使用检查器中的变换模式、数值、插值和范围;效果合适后再应用。按 方向键可将选区移动一个像素;按住 Shift 则移动十个像素。编辑范围很重要:当前帧、当前图层、当前帧中的所有图层,或选中的动画单元格都是不同的目标。提交前请检查显示的范围。
裁剪到选区
先创建选区,然后选择 Actions → Crop to Selection(⌥⌘X)。这会立即将画布裁剪到选区的矩形边界。如果没有选区,同一菜单项会显示为 Crop Canvas…。画布尺寸会在整个文档中发生变化,包括其中的图层和帧。撤销可恢复之前的尺寸和图稿。
没有选区时,Crop 会改为打开其检查器。Crop to content 会移除未使用的透明边框。Resize Canvas…(⌥⌘C)是单独的操作:选择新的宽度和高度、现有图稿的锚点,以及是否缩放内容。增大画布但不缩放内容,会在图稿周围增加空间。
保持文本可编辑
选择 Text,或选择 Layers → New Layer → Text Layer。输入文字,并使用上下文文本检查器设置字体、大小、换行、对齐方式、字距、行距、描边和阴影。使用 Transform 重新定位或调整文本大小。启用 Transform 后,双击/轻点文本即可直接在画布上编辑。
徽章示例使用薄荷绿文字,并添加一像素深色描边,使其在浅色背景上清晰易读。
保存的 Studio 项目会保留可编辑文本。导出的游戏图形则包含文本渲染后的外观。Rasterize Text Layer 会将文本转换为像素,以便进行绘画或像素调整;只有在确定不再编辑该图层上的文本时才使用此功能,也可以先复制图层。
使用调整完成作品
打开像素图层的上下文菜单并选择 Adjustments:
- **Brightness / Contrast:**调整整体亮度和对比度。
- **Hue / Saturation:**重新着色图稿或调整颜色强度。
- **Levels:**调整黑色、中间调和白色阶。
- **Blur:**柔化边缘或绘制细节。
- **Sharpen:**增强边缘对比度。
调整会先显示预览,然后才会更改文档。检查范围以及 Artwork/Mask 目标,然后选择 Apply 或 Cancel。选区可以限制受影响的区域。使用这些像素调整之前,必须先栅格化文本图层。
使用 File → Save Project(⌘S)保存可编辑版本。需要游戏素材时,请使用 File 中的导出选项。接下来可学习制作你的第一个精灵、逐帧动画,或图块和九宫格图稿。

